pikachu-Web安全-漏洞测试平台

一个好玩的Web安全-漏洞测试平台-pikachu

Pikachu上的漏洞类型列表如下:

  • Burt Force(暴力破解漏洞)
  • XSS(跨站脚本漏洞)
  • CSRF(跨站请求伪造)
  • SQL-Inject(SQL注入漏洞)
  • RCE(远程命令/代码执行)
  • Files Inclusion(文件包含漏洞)
  • Unsafe file downloads(不安全的文件下载)
  • Unsafe file uploads(不安全的文件上传)
  • Over Permisson(越权漏洞)
  • ../../../(目录遍历)
  • I can see your ABC(敏感信息泄露)
  • PHP反序列化漏洞
  • XXE(XML External Entity attack)
  • 不安全的URL重定向
  • SSRF(Server-Side Request Forgery)
  • 管理工具
  • More…(找找看?..有彩蛋!)

管理工具里面提供了一个简易的xss管理后台,供你测试钓鱼和捞cookie,还可以搞键盘记录!~每类漏洞根据不同的情况又分别设计了不同的子类。同时,为了让这些漏洞变的有意思一些,在Pikachu平台上为每个漏洞都设计了一些小的场景,点击漏洞页面右上角的”提示”可以查看到帮助信息。

如何安装和使用-同DVWA

Pikachu使用世界上最好的语言PHP进行开发-_-数据库使用的是mysql,因此运行Pikachu你需要提前安装好”PHP+MYSQL+中间件(如apache,nginx等)”的基础环境,建议在你的测试环境直接使用 一些集成软件来搭建这些基础环境,比如phpstudy,XAMPP,WAMP等,作为一个搞安全的人,这些东西对你来说应该不是什么难事。接下来:
–>把下载下来的pikachu文件夹放到web服务器根目录下;
–>根据实际情况修改inc/config.inc.php里面的数据库连接配置;
–>访问http://x.x.x.x/pikachu,会有一个红色的热情提示

“欢迎使用,pikachu还没有初始化,点击进行初始化安装!”,点击即可完成安装。

1、把pikachu放在phpstudy里面的www目录下

2、根据实际情况修改inc/config.inc.php里面的数据库连接配置;我这里把密码改为root。当然默认就好!

3、打开phpstudy,访问http://127.0.0.1/pikachu,会有一个红色的热情提示

大功告成

暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇